Using the Yamaha Rx-V1900 Driver

Home Forums V-Control General Using the Yamaha Rx-V1900 Driver

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #1253
    anika
    Participant

    Hello,

    I’ve been trying to use the pre-prepared driver for the Yamaha RX-V1900 Amp.

    I am only trying to run the Main_Power Command, which should turn Main Power on or off(standby). The “off” command works, but “on” always results in a timeout. (I have tried some other command such as get and set input but they have all been working without any issues) I have been looking into the Rx-V1900 manual, but the hex command that is sent by Main_Power:On seems to be correct.

    Is there any reason why one command would work, but not the other? Other than a mistake in the manual? Have you successfully used this driver in the past?

    #1256
    JonasStade
    Participant

    There could be a timeout time defined in the driver for this command. Then Control Show a timeout sometimes, because the response was already there a little bit earlier

    #1258
    anika
    Participant

    thanks, I have already played with the timeout values a bit to see if it makes a difference, but no luck. 🙁

    The thing is, the Main_Power:Off function puts the Amp into standby. But the Main_Power:On doesn’t seem to do anything, when the amp is in standby. When the amp is already on (because I walked over to it and pressed the on/standby button) and I run the Main_Power:On comand the display informs me that yes, the Main Power is On. But I don’t manage to turn it on remotely.

    #1260
    Dierk
    Participant

    Page 16 of the attached document describes the Power Command. Do you use the “All Zone Power”?

    #1267
    anika
    Participant

    I tried “All Zone Power” as well as “Main Zone Power”. Both work for turning the amp off, but not for turning it back on.

    I also tried the Wake on “RS-232C Access” command. No luck.

    #1268
    Dierk
    Participant

    Here is what I found in the manual concerning RS232 settings. I think all non bold settings are correct at your side, but can you check the bold ones?

    —————————————————————–
    1.2 RS-232C Settings
    *Full duplex, start-stop synchronization communication
    Baud rate 9600bps
    Data bits 8
    Parity No
    Stop bit 1bit
    Handshaking Hardware

    *The RX-V1900 RTS port outputs at low level when the AC plug is disconnected.
    If RTS output stays low even when the AC plug is connected, a problem may occur.

    —————————————————————–

    Are you sure RTS/CTS is selected?

    #1269
    anika
    Participant

    How and where do I select RTS/CTS?

    The Handshaking Hardware Setting was missing in our Lantronix Device, but after I changed this setting I still had no luck turning on the amp remotely.

    Please find attached screencap comparing the settings & statistics on Lantronix.

    Since it works to turn on our Yamaha Soundprojector remotely, I have compared the settings we have for the Soundprojector (Line 1) with the Amp (Line 6). In the statistics it lists CTS Input as “asserted” for the Soundprojector but as “not asserted” for the Amp. Not sure if this is important.

    Thanks for your help.

    #1272
    Dierk
    Participant

    It seems that, for any reason, the CTS is missing. I’m not 100% sure that this is the reason for your problem. What you can do is to connect the amp to the Soundprojector port on the Lantronix and check if the “asserted” message switch to not asserted.

    #1273
    anika
    Participant

    Okay, I unplugged the soundprojector at the Lantronix and replaced it with the AMP.

    Now Line 1 reads “CTS input: not asserted”.

    #1274
    Dierk
    Participant

    Maybe the CTS wire of the Amp is not connected? And maybe RTS as well?

    Again, I’m not really sure that the missing CTS line is the problem, but the manual says
    If RTS output stays low even when the AC plug is connected, a problem may occur.

    So maybe both lines are missing and you have only Tx,Rx and Ground connected?

    • This reply was modified 4 years, 2 months ago by Dierk.
    • This reply was modified 4 years, 2 months ago by Dierk.
    #1277
    anika
    Participant

    I replaced the serial to rj45 adapter (200.2070A) with a new one, in case the other one is broken. Now it says CTS input: asserted in the Lantronix DeviceInstaller.(see attachment)

    However, Main Level Power or All Zones Power still only work for “off” but not for “on”. 🙁

    Attachments:
    #1279
    anika
    Participant

    Turns out, the difference between “asserted” and “not asserted” has nothing to do with the new adapter. When the amp is on it says “asserted”, when it goes into standby it changes to “not asserted”.

    In comparison: the Yamaha Soundprojector still says “asserted”, even when it is on standby…

    #1280
    Dierk
    Participant

    In the protocol page 13, there is an extended command “Wake on RS-232C Access”.
    maybe someone reset this. To switch it on should work like this:
    scriptresult = chr(2)+"2BD01"+chr(3)

    #1281
    anika
    Participant

    I have already tried this. I get the ACK “On”, but when I try to turn on Main Power or All Zones Power nothing happens apart from a timeout.

    #1282
    JonasStade
    Participant

    I think you can Write Yamaha an E-Mail to find out the bug in the chain. They have an Office in the NL and they give a fast feedback. Sometimes they change One value and it takes a lot of time until it appears in a manual;)
    Like Freeze @ panasonic which is still not in the manual (instead of FRZ you use now FR1 and FR0 or something like that….)

Viewing 15 posts - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.
Scroll to top