TCP_StreamDeckConnector Problem

Home Forums V-Control General TCP_StreamDeckConnector Problem

This topic contains 4 replies, has 2 voices, and was last updated by  Dierk 2 months, 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1954

    Lemmi
    Participant

    I tried to setup the TCP_StreamDeckConnector, as described in the manual, and failed at the first moment.
    Then I tried the windows command line, to run my task “PPT1”:

    TCP_StreamDeckConnector.exe ->run->PPT1

    and failed again. However the V-Control Remote Server works fine, I could control it with a python script.

    Then I checked the TCP communication with wireshark, and found out, that TCP_StreamDeckConnector.exe opens
    a TCP connection with V-Control and closes it immediately after that. No command was transmitted.

    Finally I discovered a File PPT1 in the TCP_StreamDeckConnector program directory (size 0 bytes). Now I tried
    TCP_StreamDeckConnector.exe "->run->PPT1" on the command line, and got an Error Message in V-Control

    Cmd PPT1" / Data Task not found

    TCP_StreamDeckConnector.exe "->run->PPT1

    Is the solution for the problem. You need to type a leading " before the command string, but no trailing " after it.
    Don’t know why, but it works fine for me.

    #1955

    Dierk
    Participant

    Interesting, unfortunately I have no time to verify this right now. I am a little bit confused about the command line. Do you have the full path there? I am missing something such as “C:\” or whatever the drive is you are using.

    #1956

    Lemmi
    Participant

    The command line (Windows Command Prompt) is

    C:\Users\Authorized user\TCP_StreamDeckConnector>TCP_StreamDeckConnector.exe "->run->PPT2

    however in the Stream Deck application i have to use the following line:

    "C:\Users\Authorized user\TCP_StreamDeckConnector>TCP_StreamDeckConnector.exe" ->run->PPT2

    As you can see, the command path is surrounded by quotation marks, and the command parameters
    are following the trailing quotation mark "

    #1958

    Dierk
    Participant

    Hi Lemmi,

    “C:\Users\Authorized user\TCP_StreamDeckConnector>TCP_StreamDeckConnector.exe” ->run->PPT2

    See the bold character? that should not be there

    #1959

    Dierk
    Participant

    I mean the > character before TCP_StreamDeckConnector.exe

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.