PowerDown Watchout Display

Welcome Forums V-Control General PowerDown Watchout Display

This topic contains 10 replies, has 2 voices, and was last updated by  bjoerka 2 weeks, 1 day ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1756

    bjoerka
    Participant

    i have a question according to tcp channels and ports, used in there.

    to shutdown 2 watchout display computers, i added a command “authenticate 1” and “powerDown” each followed by a carriage return.
    the assigned channel communicates via tcp and port 3039.
    when v-control enters the run mode, it seems that the port is occupied by v-control.
    the watchout production computer is not longer able to switch to “online” to have the production computer communicate with the display computers.
    is it possible to avoid this so that the port is used only when the powerDown command is sent?

    #1757

    Dierk
    Participant

    Hi Björn, welcome to the forum.

    If you authenticate with a display computer, then the computer that sends the authenticate command becomes the master, and the production software is locked
    out.

    From Watchout Manual:

    To control a WATCHOUT display cluster via the network, connect to TCP/IP port number 3039 of one
    of the WATCHOUT display computers. The computer with which you initiate communication becomes
    the master of the cluster, and will automatically control the other cluster members,

    Unlike UDP, TCP holds a permanent connection, so if you send the authenticate command, there is a connection between V-Control and Watchout Display computer.

    In V-Control a TCP channel is automatically opened when the project file is loaded. This is necessary because usually the channel needs to be open to control the device. There is no way to change this behavior at the moment.

    What you can try is to send the authenticate command just before the PowerDown command. In this case V-Control is authenticated just for PowerDown.

    If that doesn’t work because Watchout Display Software accepts only one TCP connection, there is another work around.
    You can use V-ControlRemotePC and install it on the Display Computer.

    https://v-control.com/product/v-control-remote-pc-windows/

    and here is a Topic how to use it in your case
    https://v-control.com/product/v-control-remote-pc-windows/

    Another solution is to use a batch file and execute this with the ShellExecuteAsFunction command. Here is an HowTo:

    https://www.pcwelt.de/tipps/XP-Vista-7-Andere-Rechner-ferngesteuert-herunterfahren-1005534.html

    #1758

    Dierk
    Participant
    #1759

    bjoerka
    Participant

    thx dierk.
    i´ll look into that the next days.

    #1795

    bjoerka
    Participant

    that also works now.
    so now we have control system that fires up all projectors, watchout systems and shuts all down.

    a few problems with starting and shutting down the projectors still exist, but we will try to put all components into a seperate lan.

    maybe that helps…

    #1796

    Dierk
    Participant

    The Project you’re running on Raspberry is not very small. Maybe the Shutdown and Power On problems with the Projectors come from a heavy CPU load. I,m sure on a small x86 CPU you will not have these problems.

    V-Control asks each connected projector periodically for power, input and lamp status. Maybe it helps to reduce the intervall for theese polling commands.
    You can open the device editor, select the Projectors one after each other, and look for Monitor Commands. The increase the value for periodically execution, click “update command” and switch to the next command. If finished click the compile button.

    I’m in a train now,answering from my mobile phone, so I’m not able to give more detailed instructions.

    #1797

    bjoerka
    Participant

    ok.
    i´ll test this in the afternoon.

    #1799

    bjoerka
    Participant

    so. tests are done.
    changing the intervall helps a bit. but there are always one or two projectors that don´t shut down.
    right now we are setting up a small win10 system with an i5 processor…
    i´ll check back later…

    #1803

    bjoerka
    Participant

    the little windows machine is running now.
    much more performance than the raspberry
    and now the delay commands have the right timing
    on the raspberry, the longer the systems was running, the slower each command was performed. having the raspberry running for two days results in a very laggy interface. each click took seconds to be executed…

    but the shutdown of the projectors is still not working to 100%
    actually i am performing the whole shutdown sequence twice. one task fo each projector executes a shutdown command two times with a delay of 750ms. one sequence means all 8 projectors. that seems to solve the probem at the moment.
    changing to the win system leaves mostly one projector running, whereas with the raspberry it was mostle two or three.

    #1809

    Dierk
    Participant

    Can you send me your updated project again? I have PJ Link Simulator software and will try to reproduce this.
    But I,m still on a Job and not in the office, so it will take some days before I can start investigating.

    #1811

    bjoerka
    Participant

    yes. i´ll do so.
    no hurry. take your time
    good luck for the job 😉

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.